Probleme mit ISO-8859-15 Zeichensatz

  • Hallo Leute !


    Mal eine ganz andere Frage, dass aber auch tendenziell mit Bildschirmen zu tuhen hat.


    Ich habe Probleme mit der Darstellung des Euro Zeichens "¤".


    Der ISO-8859-15 Zeichensatz wurde ja eingeführt um den bis dahin üblichen ISO-8859-1 Zeichensatz zu ergänzen, oder genauer, er ersetzt 6 Zeichen zum ISO-8859-1 Satz inkl. dem hinzugefügten ¤ Zeichen an der 164. Stelle des Ascii Zeichensatzes.


    Beim Browser kann ich nun einstellen, ob Webseiten Standardmäßig mit dem 1'er oder dem 15'er Zeichensatz angezeigt werden sollen.


    Um das ¤ Zeichen zu sehen, habe ich logischerweiße den ISO-8859-15 Zeichensatz aktiviert.
    Aber wundersammerweise erscheinen dann auf Seiten wie dieser:



    nur Fragezeichen statt dem ¤ Symbol.
    Bei Benutzung des 1'er Satzes aber tatsächlich korrekt die ¤ Zeichen, obwohl dieses dort eigentlich gar nicht vorhanden ist.


    Weiß jemand rat ?



    Neutrino



    P.S. Benutze Linux, so dass ich das Windows-1252 Zeichensatz Problem umgehe.

  • O.K., das bedeutet euer Browser kann den ISO-8859-15 Zeichensatz verarbeiten. :))
    '
    Meine Frage ist, ob ihr auf der verlinkten Seite wenn ihr euch weiter zu den Angeboten hangelt '¤' Zeichen oder '?' Zeichen seht ?


    Und zwar


    1. Wenn ihr manuell im Browser den ISO-8859-15 Zeichensatz erzwingt


    2. Wenn ihr den ISO-8859-1 Zeichensatz erzwingt ?


    Wann gibt es ?, wann ¤ Zeichen ?



    Neutrino



    P.S. Könnte auch sein, dass diese Latin1 im Falle von ISO-8859-1 und Latin0(besser) oder Latin9(schlechter) bezeichet werden.
    Oder Westlich-1 und Westlich-0 oder Westlich-9.


    Oder bei Obi...

  • Quote

    Original von Jetson
    Ich auch nicht.
    Wenn ich jetzt mal das "ý" tippe was siehst du bei dir anstelle?


    Wenn ich den ISO-8859-15 Zeichensatz erzwinge ein Fragezeichen und beim ISO-8859-1 ein Euro Zeichen, verrückt was ?



    Neutrino

    • Official Post

    Ich weiss nicht was Du siehst, aber Dein Beitrag sieht so aus:

  • O.K. jetzt habe ich ein Problem mein Fragezeichen bleibt ein Fragezeichen, so weit so gut.


    Aber das Euro Zeichen wird zum intern. Währungszeichen gemacht, auch Dübel genannt.


    Und euer Euro Zeichen erscheint bei mir im ISO-8859-15 Modus als Fragezeichen und bei ISO-8859-1 als Eurozeichen, ich verstehe das nicht.


    Probiert doch mal wie beschrieben abwechselnd den ISO-8859-15 und den ISO-8859-1 Zeichensatz zu erzwingen.


    Was passiert dann hiermit: ¤, ¤, ¦, ¨, ´, ¸, ¼, ½, ¾ ???



    Neutrino



    P.S.: Ich fange hier langsam an durchzudrehen.

    • Official Post

    Keine Ahnung wo ich das beim IE einstelle. Habe mal gesucht aber nichts gefunden. Wenn Du mir sagst wo, dann teste ich es auch.

  • Tut mir Leid, benutze unter Linux kein IE :D


    (Um Gottes Willen bitte nicht als Flame-War Aufruf verstehen, tut das mir und dem Forum bloß nicht an!!!)


    Versuche mal eine Option unter Ansicht zu finden, oder nach Zeichensatz in den "Internetoptionen" zu suchen.
    Ich kann mich noch an eine Stelle errinnern, wo ich Probeweise mal einen japanischen eingestellt hatte.


    Wenn du es nicht findest, evtl. weiß ich spätestens morgen mehr.


    An sonsten, ihr da, ihr Linux User die jetzt grinsend vor dem Rechner sitzen.
    Ein Mituser braucht eure Hilfe. Also das Grinsen in ein Kribbeln in den Fingern verwandeln und los.



    Neutrino

  • Was, diese Text-Browser sind tatsächlich noch im Einsatz ?! :D


    Hinweis wie oben, jeweils einen Zeichensatz erzwingen und dann melden..



    Neutrino

  • @Prad: Habe mich mal mit einer uralt IE Version herumgeplagt.


    Bei den Internetoptionen gibt es die Schaltflächen Sprache und Schriftart. Bei der Schriftart kann man eine benutzerdefinierte angeben und dort wiederum den Zeichensatz ändern.
    Weiß der Kuckuck wie das jetzt bei den aktuelleren IE Versionen aussieht.



    Neutrino

  • Bei aktuellen IEs gibt es die Menüpunkte Schiftart und Codierung. Sie enthalten jeweils ein Untermenü. Das Untermenü zu Schaltfläche besteht aus "Sehr groß", "Größer", "Mittel", "Kleiner", "Sehr klein". Das Untermenü Codierung ermöglicht es dem User, eine Sprachregion zu wähjlen (z.B. Westeuropa, Osteuropa, Kyrillisch, Japanisch, Griechisch...) jeweils (teilweise) in den Varianten ISO, Windows, DOS und noch weitere..

  • Habe mich gerade etwas informiert.


    Das Problem liegt nicht bei mir, sondern an den Windows Benutzern, weil das Euro Zeichen an der 128. Stelle in dem Windows Systemzeichensatz: Windows-1252 abgelegt ist.


    Und beim eigentlich zu benutzenden ISO-8859-15 an der 164. Stelle.


    Weiß einer von den Linux Usern nun, was ich am besten einstellen sollte, ISO-8859-15 oder ISO-8859-1 ?


    Und warum sehe ich beim ISO-8859-1 Zeichensatz ein Euro Zeichen, wenn es dort garnicht vorhanden sein sollte ?



    Neutrino

  • Ich kenne das Problem eigentlich nur aus dem eMail-Bereich ...
    Nach der Veröffentlichung von -15 hatte ich meinen Mailer umgestellt, aber wenn man nur immer Beschwerden kriegt, weil bei den Adressaten sämtliche Sonderzeichen durcheinandergewürfelt herauskommen ... mittlerweile schreibe ich auch wieder mit -1 und "EUR", unter Win wie auch unter Linux.


    [ posted with Mozilla 1.3@Mandrake 9 und ISO-8859-1 ]


    Edit:
    €-Zeichen
    wunderlicher Weise kann ich weiterhin Neutrinos EUR sehen und Prad/Jetsons nicht.
    Und, ja, ich habe den Browser nach der Umstellung von -15 zurück auf -1 geschlossen :)

    Du nutzt die Informationen von [p]rad.de und möchtest, dass diese Seite auch in Zukunft existiert? Dann gib dir einen Ruck und werde Premium-Mitglied !

    Edited once, last by Metallurge ().

  • O.K.


    Danke, mal wieder ein kompetenter Tipp von dir.


    Du schreibst, du benutzt nur noch "EUR" als Ersatz.


    Kannst du mit dem -1 Satz ein Euro Zeichen eintippen ?


    Wenn ja, schick mir das dann mal hier vorbei.


    Ausserdem kannst du bei Mozilla über Ansicht, Zeichenkodierung einen bestimmten Zeichensatz auswählen.


    Falls der -15'er nicht dabei ist, kannst du im selben Menü unter Anpassen, diesen aus einer ganzen Liste zu den aktiven hinzufügen.
    Wenn du jetzt mal den einen mal den anderen erzwingst, wie ändert sich dann die Zeichenreihe in einem meiner vorherigen Postings.



    Neutrino

  • Also ... jetzt mal das ganze in 8859-15:


    Das EUR-Zeichen in deinem Ursprungsposting ist richtig dargestellt, dafür sind jetzt bei Prad und Jetson nur noch Fragezeichen. Umlaute werden überall richtig angezeigt.


    Wie es mit 8859-1 aussieht editiere ich in das obige Posting


    PS: Mein eigenes -1-EUR-Zeichen erscheint unter -15 auch als Fragezeichen


    HTH
    Metallurge

    Du nutzt die Informationen von [p]rad.de und möchtest, dass diese Seite auch in Zukunft existiert? Dann gib dir einen Ruck und werde Premium-Mitglied !

    Edited once, last by Metallurge ().

  • Ich habe mit dem Euro Zeichen unter Linux bei Mozilla und Opera keine Probleme.
    Welchen Browser verwendest du?


    Kenne allerdings das Problem mit den Umlauten (ä, ü, ö) unter Linux :D

  • @all: Ich probiere es jetzt einmal mit -1:


    € , ' , " , | ?


    Wie siehts jetzt aus ?



    Neutrino


    Edit: Jetzt sehe ich unter -1 das Euro Zeichen, aber warum ?
    Eigentlich sollte es dort gar nicht vorhanden sein !?