PixChanger - Programm gegen SubPixel-Fehler (von Phantom 1)

  • Quote

    Original von Wolfenstein 2k2
    Ui, Problem, bei jedem Win-Neustart schmiert das Programm ab (Runtime Error 216 at 00403846, bei vorangehender Fehlermeldung seitens Windows). Das habe ich beinahe befürchtet, denn irgendwie möchte das Programm nicht, dass man es mehrmals in einer Windowssitzung startet. Bei ersten Mal klappt es meistens, beende ich dann das Programm und lade es neu, kommt dann der Fehler.


    Hmm...., bei mir gehts immer so oft ich es auch starte.
    Du bist allerdings nicht der erste mit diesem Phänomen, das werde ich mal genauer unter die Lupe nehmen müssen

  • Quote

    Original von Nash
    Ich habe einen dauerhaft rot leuchtenden Pixel auf meinem Bildschirm. Ausser wenn das Bild weiß ist sieht man den Pixelfehler nicht.


    Habe das Programm auch getestet aber es tut sich nichts. Wenn der Hintergrund schwarz ist leutet der Pixel rot und ich wähle rot aus. Ist der Hindergrund weiß sieht man den Pixelfehler nicht mehr, was soll ich dann für eine Farbe auswählen?


    MfG
    Nash


    Hallo, ich habe exakt den selben Fehler mit meinem neuen Hyundai L90D+. Der Fehler stört mich eigentlich nicht, außer wenn ich Videos im 16:9 schaue und in den "schwarzen Balken" dann ein roter Pixel leuchtet. Was muss ich machen, damit der Pixel schwarz ist und nicht mehr rot?
    Danke, CU Primal

  • bei mir ist auch ein roter fehlerpixel, wenn ich dann beim ersten, schwarzen hintergrund, die farbe rot wähle, wird der pixel bei schwarzem hintergrund aber weiß... und im weißen hintergrund kann ich den roten pixel gar nicht mehr sehn.... deswegen auch dieselbe frage was ich machen muss damit der rote pixel bei dunklem hintergrund schwarz und bei hellem hintergrund weiß angezeigt wird?!
    Danke

  • also ich hab nen roten subpixelfehler auf wschwarzem hintergrund.
    wenn ich das tool starte. den pixel auswähle, farbe rot wähle. dann passiert nix.


    der is immernoch rot auf schwarzem hintergrund ^^

  • Japp, das Tool ist ein Witz. Wollte damit gestern auch meinen PF wegkriegen, nur ich sollte dann eine Farbe wählen, die dem Pixel am nächsten kommt, nur dann hat der Pixel eben nicht mehr schwarz, sondern je nach ausgewählter Farbe geleuchtet und deshalb ist das Tool IMO total witzlos. Am nächsten käme einem toten Pixel natürlich die Farbe schwarz, was zum Ergebnis hatte, dass der PF nur noch besser zu sehen war. Würde mich ja mal interessieren, ob irgendjemand mit dem Tool schon Erfolg hatte.


    Gruß


    Gorn

  • Hm, Du hast einen toten Pixel der immer Schwarz ist aber mit dem Tool auf jede der Grundfarben eingestellt werden kann? Wie kann das dann ein toter Pixel sein, der dürfte doch so oder so nur schwarz sein, denn ansonsten würde er ja gehn. 8o


    Das Tool ist übrigends nur für Subpixelfehler, nicht für richtige Pixelfehler.

  • Quote

    Original von Hoto
    Hm, Du hast einen toten Pixel der immer Schwarz ist aber mit dem Tool auf jede der Grundfarben eingestellt werden kann? Wie kann das dann ein toter Pixel sein, der dürfte doch so oder so nur schwarz sein, denn ansonsten würde er ja gehn. 8o


    Das Tool ist übrigends nur für Subpixelfehler, nicht für richtige Pixelfehler.


    Gute Frage, war aber so. Ich habe mit dem Nokia-Monitor-Test geprüft und da war der Pixel bei allen Farben schwarz. Dann habe ich das Tool genommen und man sollte einstellen, welcher Farbe der Pixel am nächsten kommt. Da das nunmal schwarz war, habe ich auch schwarz ausgewählt, was dann dazu führte, dass der Pixel irgendwie noch schwarzer wurde und somit noch besser zu sehen war. Wenn ich eine andere Farbe wählte, hat der Pixel eben je nach Farbe ganz leicht grün, rot etc. geleuchtet. Was das nun genau für eine Art von PF war, kann ich dir nicht sagen und es ist mir eigentlich auch egal, da Geräte mit PF für mich grundsätzlich nicht in Frage kommen. Ein Staubkorn war es aber definitiv nicht, denn da habe ich genau drauf geachtet, da sich einige PF vorher bereits als Staubkörner entpuppten, bis auch den einen halt.


    Gruß


    Gorn

  • Hallo!


    Also ich bin zur Zeit neu hier und hab mich nun das erst einmal angemeldet. Ich verfolge seit längerem mit großem Interesse die Beiträge in diesem Forum und möchte mich vorab einmal bei allen Usern, die sich hier beteiligen und Testberichte etc. verfassen, herzlich dafür danken.
    Diese Berichte haben mich nun auch dazu bewegt, ein ViewSonic VX924 zu kaufen. Also bin ich zu einem Händler hier um die Ecke, um mir das Produkt vor dem Kauf anzuschauen. Alles soweit kein Problem,doch beim Pixelfehler suchen, hab ich wohl doch einen übersehen. Der Händler möchte den TFT auch nich zurücknehmen.


    Daher meine Frage: Kann ich das defekte Pixel mittels der Software auch komplett abschalten? Also es leuchtet grün und nervt schon sehr beim DVD-Schauen. Und grün lässt sich mit derSoftware so gut,wie nicht beheben. Eine Abschaltung wäre perfekt :)


    Vielen Dank schoneinmal für Eure Hilfe...
    Und das nicht nur bei diesem Thema, sondern in allen Belangen bisher!


    MfG
    General_Ho a.k.a. Stefan

  • also so wie ich das versteh, kannst du damit n wirklichen pixelfehler wohl nicht ausschalten, weil der ja nicht aufgrund von ner fehlerhaften darstellung des betriebssystems, sondern von deinem Monitor verursacht wird und daran kann die Software ja nichts ändern... mein roter Punkt ist auch immer noch sichtbar, aber ich hab gehört das bei manchen solch ein pixelfehler angeblich mit der zeit verschwunden ist

  • Wäre schön, wenn er einfach verschwinden würde :)


    Zum Programm: Ich hab es doch richtig verstanden, dassmit demProgramm die umliegenden Pixel vom Farbwert her so berechnet werden, dass der einzelne Pixelfehler nicht mehr so auffällt.
    Wenn es Softwareseitig möglich ist, andere Pixel zu manipulieren, dann sollte es doch an sich auch die Möglichkeit geben, das defekte Pixel abzustellen,oder!?


    Hmm... wenn das möglich wäre und im Moment bei dem Programm noch nicht funktioniert,könnte man das eventuell ja mal so erweitern.


    Hatte ich den einen Post falsch verstanden,wo jemandem erklärt wurde,wie das gehen soll? Denn anscheinend hat es bei ihm funktioniert. Das Problem ist jedoch, dass ich es nicht so lösen kann, weil der PF auf weiß absolut nicht zu sehen ist :(


    Gruß
    General_Ho


    P.S.: Fehlende Leerzeichen bescheinigen das Alter meiner Space-Taste ;)

  • ja, das problem mit dem weißen hintergrund hat ich auch... also so wie ich das sehe is der pixelfehler ja n fehler an der hardware, also eigentlich n kaputter pixel und mit dem programm veränderst du ja nur die pixel, die noch ganz sind und wie willst du über eine software einen pixel bearbeiten der eigentlich gar nicht existiert weil er kaputt ist?

  • Hi,


    Ich frage mich wie ich den PixChanger schalten muss damit der Pixel entweder weniger auffällt oder ganz deaktiviert wird.


    Also ich habe einen Pixelfehler der ständig blau leuchtet, zumindest auf schwarz, rot, grün und denke auch blau. Von Haus aus wird er aber bei weißer Umgebung auch weiß. (Da frage ich mich schon wie das geht bzw. welcher Subpixel da defekt ist.)


    Nun gut, auf blau störts mich sowieso nicht ;) grün sieht man auch nur etwas, wenn man direkt mit dem Auge darauf schaut. Rot kann man noch wahrnehmen aber nur sehr gering und auch nur wenn man sich darauf konzentriert. Aber bei schwarzem Hintergrund sieht man es ganz eindeutig, schon z.B. beim Hochfahren oder Filme mit schwarzem Balken bzw. Spiele im Spec-Modus.


    Nun habe ich zuerst probiert den Pixel auf schwarzem Hintergrund zu wählen und habe Ihm die Farbe blau zugewiesen (es ist aber eher mehr Hellblau während pixchanger ein dunkelblau vorgibt). Daraus ergibt sich dann meist ein weißer Pixel der jedoch so gut wie schlimmer auffält als der blaue.


    Dann wollte Ich einmal den Pixel ganz abschalten (Auf weißem Hintergrund schwarz gewählt) Da war er dann plötzlich die ganze Zeit dunkelblau - auch bei weißen Flächen. ?(


    Bitte dazu ebenfalls hier reinschauen.

  • Quote

    Original von Towelie
    Ich frage mich wie ich den PixChanger schalten muss damit der Pixel entweder weniger auffällt oder ganz deaktiviert wird.


    Zum verständniss: Das Programm PixChanger ändert nur das Bild von der Grafikkarte und nicht direkt am TFT.


    Quote

    Original von Towelie
    Also ich habe einen Pixelfehler der ständig blau leuchtet, zumindest auf schwarz, rot, grün und denke auch blau. Von Haus aus wird er aber bei weißer Umgebung auch weiß. (Da frage ich mich schon wie das geht bzw. welcher Subpixel da defekt ist.)


    Ein Pixel besteht aus 3 Grundfarben (Rot, Grün, Blau) die eine unterschiedliche Helligkeit annehmen können. Wenn jetzt bei einem Pixel alle 3 Grundfarben leuchten entsteht die Farbe: weiß! Wenn alle 3 Grundfarben aus sind, hast du schwarz.


    So wie es aussieht ist bei dir nur der blaue Subpixel defekt bzw dieser leuchtet immer! Es gibt übrigens auch defekte Subpixel die garnicht mehr leuchten können.


    Quote

    Original von Towelie
    Nun habe ich zuerst probiert den Pixel auf schwarzem Hintergrund zu wählen und habe Ihm die Farbe blau zugewiesen (es ist aber eher mehr Hellblau während pixchanger ein dunkelblau vorgibt). Daraus ergibt sich dann meist ein weißer Pixel der jedoch so gut wie schlimmer auffält als der blaue.


    Ja so soll mein Programm auch arbeiten, die weiße Farbe ist neutraler als die blaue Farbe.


    Quote

    Original von Towelie
    Dann wollte Ich einmal den Pixel ganz abschalten (Auf weißem Hintergrund schwarz gewählt) Da war er dann plötzlich die ganze Zeit dunkelblau - auch bei weißen Flächen.


    Das ist völlig korrekt! Mein Programm setzt diesen Pixel dann immer auf schwarz (bei der Grafikkarte), da jedoch beim Monitor der blaue Farbanteil immer leuchtet wird der Pixel trotzdem blau angezeigt.


    Allerdings wundere ich mich, das du den Pixel überhaupt auf dem weißen Hintergrund (im PixChanger) sehen konntest?


    mfg?

  • Quote

    Original von Phantom1
    Zum verständniss: Das Programm PixChanger ändert nur das Bild von der Grafikkarte und nicht direkt am TFT.


    Das ist schon klar, dass dein Tool nicht direkt im Monitor herumpfuscht.


    Quote

    Original von Phantom1
    Ein Pixel besteht aus 3 Grundfarben (Rot, Grün, Blau) die eine unterschiedliche Helligkeit annehmen können. Wenn jetzt bei einem Pixel alle 3 Grundfarben leuchten entsteht die Farbe: weiß! Wenn alle 3 Grundfarben aus sind, hast du schwarz.


    So wie es aussieht ist bei dir nur der blaue Subpixel defekt bzw dieser leuchtet immer! Es gibt übrigens auch defekte Subpixel die garnicht mehr leuchten können.


    Ebenfalls nun klar wie die Farben entstehen, aber wenn jetzt alle drei Farben benötigt werden um Weiß darzustellen (was er ja kann) bedeutet das wohl, dass dennoch alle 3 Subpixel prinzipiell leuchten können. Warum ändert sich dann bei z.B Rot nicht die Farbe? Es ist immer ein Hellblau außer eben auf Weiß. Sollte nicht blau immer leuchten und dann jeweilige Farben hinzu?


    Quote

    Original von Phantom1
    Ja so soll mein Programm auch arbeiten, die weiße Farbe ist neutraler als die blaue Farbe.


    Weiß stört leider oft sogar stärker als das Hellblau aufgrund der jeweiligen Umgebungsfarben in dem Bereich. Es wird dann aber auch komischer weise auf bei weißer Umgebung wieder blau? Grau wäre vl. nicht schlecht, wie muss ich das so einstellen? Oder eben eventuell ganz abschalten. Aber ich fürchte das wird so nicht gehen.


    Quote

    Original von Phantom1
    Das ist völlig korrekt! Mein Programm setzt diesen Pixel dann immer auf schwarz (bei der Grafikkarte), da jedoch beim Monitor der blaue Farbanteil immer leuchtet wird der Pixel trotzdem blau angezeigt.


    Allerdings wundere ich mich, das du den Pixel überhaupt auf dem weißen Hintergrund (im PixChanger) sehen konntest?


    mfg?


    Natürlich konnte ich den Pixel auf weißem Hintergrund nicht sehen (dort war er ja weiß). Dazu musste ich zunächst den Pixel im schwarzen Bereich auswählen (das habe ich am besten mit der Tastatur gemacht, geht eh ganz leicht zunächst auf horizontaler Ebene mit den seitlichen Linien des Fadenkreuzes gleichkommen 2 od. 3 mal runter, dann auf der Vertikalen mit den obrigen Fadenkreuzlinien ausrichten und wieder 2,3 hinauf) und dann die Farbe. (btw: hier wäre es ev. günstig, per Zahlen die Farbe auszuwählen damit man das Fadenkreuz nicht bewegen muss. Ich habe nämlich: ) Anschließend wieder selbige Positionierung im schwarzen Bereich getätigt aber nun mit Rechtsklick und dann Linksklick im weißen Bereich.


    Also offen bleibend welche Lösung in meinem Fall wohl am besten ist? Wenn es denn überhaupt nicht vl. ein Grund für Reklamation ist da ich mir nicht sicher bin ob es nur ein Pixel ist. Siehe den auch schon vorhin angeführten Link.

  • Quote

    Original von Towelie
    Ebenfalls nun klar wie die Farben entstehen, aber wenn jetzt alle drei Farben benötigt werden um Weiß darzustellen (was er ja kann) bedeutet das wohl, dass dennoch alle 3 Subpixel prinzipiell leuchten können. Warum ändert sich dann bei z.B Rot nicht die Farbe? Es ist immer ein Hellblau außer eben auf Weiß. Sollte nicht blau immer leuchten und dann jeweilige Farben hinzu?

    Ja wie gesagt, der blaue Subpixel leuchtet bei dir immer und da für weiß auch der blaue Subpixel leuchten muss wird bei dir das weiß korrekt dargestellt. Anders wäre es wenn der Subpixel garnicht nicht mehr leuchten kann. Bei einer Roten Hintergrundfarbe müsste der Pixel bei dir eher pink aussehen (Rot+Blau).


    Quote

    Das habe ich mir auch schon fast so gedacht ;)


    [QUOTE][QUOTE]Original von Towelie
    Also offen bleibend welche Lösung in meinem Fall wohl am besten ist? Wenn es denn überhaupt nicht vl. ein Grund für Reklamation ist da ich mir nicht sicher bin ob es nur ein Pixel ist.


    Wenn du willst kann du ja mal dieses Programm downloaden. Das programm ist auch von mir, es dient mir nur zum testen bzw zum simulieren von defekten Pixeln. Man kann dort nämlich sehr gut sehen wie ein defekter Subpixel bei einer bestimmten Hintergrundfarbe aussieht, vielleicht kannst du das ja mal überprüfen ob es mit deinem "echten" fehlerpixel übereinstimmt.


    Kurze erklärung dazu: Mit den 3 reglern links kann man die Hintergrundfarbe einstellen. Auf der rechten seite gibt man an, welcher Subpixel (R=Rot, G=Grün, B=Blau) defekt ist (entweder AN = immer leuchtet oder AUS = nie leuchtet). Das programm ist wenn du es startest gleich richtig für dich eingestellt (Blau=AN).


    Unten siehst du jetzt 4 farbige kästchen.
    "Normal" bedeutet, es sieht so aus wie es auch auf dem TFT aussehen müsste (also ohne das Programm PixChanger)!
    "Schwarz" ist das gleiche, als wenn man im PixChanger die Farbe schwarz wählt
    "Algo1" ist das gleiche, als wenn man im PixChanger die korrekte Farbe auswählt
    "Algo2" ist für dich bedeutungslos


    mfg

  • Achja. also ich habe jetzt nochmal genau geschaut, wird eh pink. Und bei grün türkis.


    Dein anderes Programm habe ich auch getestet und ja die Farben stimmen überein mit der Ausnahme dass ich mit aktiviertem PixChanger (Blau=An) bei normal weißer Fläche tatsächlich blau habe ?(


    Wie dem auch sei, ich habe es jetzt mehrmals probiert mit verschiedenen Mustern und der Pixelfehler ist ohne Pixchanger weniger aufgefallen als mit. Ausserdem stört mich der Fehler hauptsächlich bei schwarzen Flächen, wo das Programm aber auch nichts machen kann (sieht man auch im pix_simulate).


    Fürchte wohl Ich werde damit Leben müssen oder wenn geht noch einschicken.


    Ich habe jetzt hier noch ein paar Fotos gemacht einerseits mit PixChanger (Pix1-4) und dann logischer weise auch ohne (norm1-5). Auch ein Video ist dabei. Wirkt nicht so ganz nach mehreren Pixelfehlern? Komisch sieht es aber bei Verwendung des PixChangers schon aus. Mit freiem Auge wirkt es so als wäre dort ein Kästchen blau und daneben ein halbes weißes.

  • Hallo,


    Phantom1:


    Das Programm ist wirklich super. Aber ich habe folgendes Problem:


    Bei mir leuchtet ein weißer Sub-Pixel. Man sieht ihn kaum. Also soll ich beim schwarzen Hintergrund den Pixel markieren und dann angeben, dass er die Farbe weiß hat.
    Das Problem: danach sieht der Pixel noch viel schlimmer aus. Muss ich vll. eine andere Farbe wählen?


    Hab es auch mal an einer Stelle probiert wo kein Pixelfehler ist, da ist dann ebenfalls ein weißer Punkt. Der sollte doch schwarz sein, damit man ihn nicht sieht..?


    Ich dachte an schwarz, aber die Farbe gibts da leider nicht. Ich hoffe, jemand kann mir helfen.


    LG